summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml38
1 files changed, 13 insertions, 25 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9fcca11..9a24ac3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,33 +3,21 @@ name = "arbs"
3edition = "2021" 3edition = "2021"
4version = "0.1.0" 4version = "0.1.0"
5 5
6[features]
7default = ["notifications"]
8notifications = ["dep:notify-rust"]
9
6[dependencies] 10[dependencies]
7color-eyre = "0.6.3"
8dirs = "5.0.1" 11dirs = "5.0.1"
9gethostname = "0.5.0" 12gethostname = "0.5.0"
10serde_json = "1.0.128" 13notify-rust = { version = "4.11.3", optional = true}
14serde_json = { default-features = false, version = "1.0.128" }
11thiserror = "1.0.63" 15thiserror = "1.0.63"
12toml = "0.8.19" 16toml = { default-features = false, version = "0.8.19" }
13tracing = "0.1.40" 17tracing = { default-features = false, version = "0.1.40" }
14tracing-appender = "0.2.3" 18tracing-appender = "0.2.3"
15 19clap = { version = "4.5.17", features = ["derive"] }
16[dependencies.clap] 20config = { version = "0.14.0" }
17version = "4.5.17" 21serde = { version = "1.0.209", features = ["derive"] }
18features = ["derive"] 22tracing-subscriber = { version = "0.3.18", features = ["env-filter"] }
19 23uuid = { version = "1.10.0", features = ["v4"] }
20[dependencies.config]
21version = "0.14.0"
22features = ["ini", "toml", "json5", "ron", "json", "convert-case", "async"]
23default-features = false
24
25[dependencies.serde]
26version = "1.0.209"
27features = ["derive"]
28
29[dependencies.tracing-subscriber]
30version = "0.3.18"
31features = ["env-filter"]
32
33[dependencies.uuid]
34version = "1.10.0"
35features = ["v4"]