summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorFxQnLr <[email protected]>2024-02-25 16:14:56 +0100
committerFxQnLr <[email protected]>2024-02-25 16:14:56 +0100
commit03bea24f9de698375033af92a08762446d0e20cc (patch)
tree71b696ddcdc14f36115155be7f287fc0cb43e16d /Cargo.toml
parentcd73d51fba4a7d24b5ef12cb7d23054ab922cb67 (diff)
downloadwebol-cli-03bea24f9de698375033af92a08762446d0e20cc.tar
webol-cli-03bea24f9de698375033af92a08762446d0e20cc.tar.gz
webol-cli-03bea24f9de698375033af92a08762446d0e20cc.zip
Closes #2. Config and setup stuff
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml25
1 files changed, 12 insertions, 13 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ca76349..461b0bf 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
1[package] 1[package]
2name = "webol-cli" 2name = "webol-cli"
3version = "0.1.0" 3version = "0.2.0"
4edition = "2021" 4edition = "2021"
5 5
6# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html 6# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
@@ -10,15 +10,14 @@ name = "webol"
10path = "src/main.rs" 10path = "src/main.rs"
11 11
12[dependencies] 12[dependencies]
13clap = { version = "4.4.6", features = ["derive"] } 13clap = { version = "4.5", features = ["derive"] }
14clap_complete = "4.4.4" 14clap_complete = "4.5"
15config = "0.13.3" 15config = "0.14"
16dirs = "5.0.1" 16dirs = "5.0"
17futures-util = "0.3.29" 17futures-util = "0.3"
18indicatif = "0.17.7" 18indicatif = "0.17"
19once_cell = "1.18.0" 19reqwest = { version = "0.11", features = ["blocking"] }
20reqwest = { version = "0.11.22", features = ["blocking"] } 20serde = "1.0"
21serde = "1.0.189" 21serde_json = "1.0"
22serde_json = "1.0.107" 22tokio = { version = "1.36", features = ["macros", "rt-multi-thread", "io-std"] }
23tokio = { version = "1.33.0", features = ["macros", "rt-multi-thread", "io-std"] } 23tokio-tungstenite = "0.21"
24tokio-tungstenite = "0.20.1"