summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml27
1 files changed, 14 insertions, 13 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ca76349..36b08c5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
1[package] 1[package]
2name = "webol-cli" 2name = "webol-cli"
3version = "0.1.0" 3version = "0.2.0"
4edition = "2021" 4edition = "2021"
5 5
6# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html 6# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
@@ -10,15 +10,16 @@ name = "webol"
10path = "src/main.rs" 10path = "src/main.rs"
11 11
12[dependencies] 12[dependencies]
13clap = { version = "4.4.6", features = ["derive"] } 13anyhow = "1.0"
14clap_complete = "4.4.4" 14clap = { version = "4.5", features = ["derive"] }
15config = "0.13.3" 15clap_complete = "4.5"
16dirs = "5.0.1" 16config = "0.14"
17futures-util = "0.3.29" 17dirs = "5.0"
18indicatif = "0.17.7" 18futures-util = "0.3"
19once_cell = "1.18.0" 19indicatif = "0.17"
20reqwest = { version = "0.11.22", features = ["blocking"] } 20reqwest = { version = "0.11", features = ["blocking"] }
21serde = "1.0.189" 21serde = "1.0"
22serde_json = "1.0.107" 22serde_json = "1.0"
23tokio = { version = "1.33.0", features = ["macros", "rt-multi-thread", "io-std"] } 23thiserror = "1.0"
24tokio-tungstenite = "0.20.1" 24tokio = { version = "1.36", features = ["macros", "rt-multi-thread", "io-std"] }
25tokio-tungstenite = "0.21"