aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorFxQnLr <[email protected]>2024-02-12 16:00:45 +0100
committerGitHub <[email protected]>2024-02-12 16:00:45 +0100
commitc663810817183c8f92a4279236ca84d271365088 (patch)
tree0c844cc883e5e474a9cdad30004108852f13f903 /Cargo.toml
parentda6367885d31698464e1bec122e3e673974427c6 (diff)
parent9139d76cb1cf462820b2ddfa80d9a8d55bb30996 (diff)
downloadwebol-c663810817183c8f92a4279236ca84d271365088.tar
webol-c663810817183c8f92a4279236ca84d271365088.tar.gz
webol-c663810817183c8f92a4279236ca84d271365088.zip
Merge pull request #14 from FxQnLr/axum7
Axum7 & config changes
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml30
1 files changed, 15 insertions, 15 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3207453..0fb250a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,22 +1,22 @@
1[package] 1[package]
2name = "webol" 2name = "webol"
3version = "0.3.0" 3version = "0.3.1"
4edition = "2021" 4edition = "2021"
5 5
6# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html 6# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
7 7
8[dependencies] 8[dependencies]
9axum = { version = "0.6.20", features = ["headers", "ws"] } 9axum = { version = "0.7", features = ["ws"] }
10tokio = { version = "1.33.0", features = ["macros", "rt-multi-thread"] } 10tokio = { version = "1.34", features = ["macros", "rt-multi-thread"] }
11tracing = "0.1.40" 11tracing = "0.1"
12tracing-subscriber = { version = "0.3.17", features = ["env-filter", "local-time", "time"] } 12tracing-subscriber = { version = "0.3", features = ["env-filter", "local-time", "time"] }
13time = { version = "0.3.30", features = ["macros"] } 13time = { version = "0.3", features = ["macros"] }
14serde = { version = "1.0.190", features = ["derive"] } 14serde = { version = "1.0", features = ["derive"] }
15serde_json = "1.0.107" 15serde_json = "1.0"
16config = "0.13.3" 16config = "0.14"
17once_cell = "1.18.0" 17sqlx = { version = "0.7", features = ["postgres", "runtime-tokio"]}
18sqlx = { version = "0.7.2", features = ["postgres", "runtime-tokio"]} 18surge-ping = "0.8"
19surge-ping = "0.8.0" 19axum-macros = "0.4"
20axum-macros = "0.3.8" 20uuid = { version = "1.6", features = ["v4", "fast-rng"] }
21uuid = { version = "1.5.0", features = ["v4", "fast-rng"] } 21dashmap = "5.5"
22dashmap = "5.5.3" 22color-eyre = "0.6"