aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorFxQnLr <[email protected]>2024-03-04 21:37:55 +0100
committerFxQnLr <[email protected]>2024-03-04 21:37:55 +0100
commit0a058ba2064d323451462a79c71580dea7d8ec8c (patch)
tree3e0a5a8c2d48aac8b1ff1720455db47a0c50386a /Cargo.toml
parent0920c86de3523785b5f4ac67e2090f0736f9fcb2 (diff)
downloadwebol-0a058ba2064d323451462a79c71580dea7d8ec8c.tar
webol-0a058ba2064d323451462a79c71580dea7d8ec8c.tar.gz
webol-0a058ba2064d323451462a79c71580dea7d8ec8c.zip
Closes #19. Added OpenApi through `utoipa`
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 5 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8a86115..b0a8cd2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
1[package] 1[package]
2name = "webol" 2name = "webol"
3version = "0.3.2" 3version = "0.3.3"
4edition = "2021" 4edition = "2021"
5 5
6# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html 6# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
@@ -21,6 +21,8 @@ uuid = { version = "1.6", features = ["v4", "fast-rng"] }
21dashmap = "5.5" 21dashmap = "5.5"
22color-eyre = "0.6" 22color-eyre = "0.6"
23thiserror = "1.0" 23thiserror = "1.0"
24ipnetwork = "0.20.0" 24ipnetwork = "0.20"
25mac_address = { version = "1.1.5", features = ["serde"] } 25mac_address = { version = "1.1", features = ["serde"] }
26tracing-appender = "0.2.3" 26tracing-appender = "0.2.3"
27utoipa = { version = "4.2", features = ["axum_extras"] }
28utoipa-swagger-ui = { version = "6.0", features = ["axum"] }