aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorFxQnLr <[email protected]>2023-11-06 11:09:34 +0100
committerGitHub <[email protected]>2023-11-06 11:09:34 +0100
commit1cd2a8e4aecfaad2a8385a6bea61580209b86398 (patch)
treec357bcaca0681caf9a6742c857bb494dc4315900 /Cargo.toml
parentd9d7b125e4fcaa3aedd7b57a69e6880e012ccf33 (diff)
parent32561060a8dc6fc6118498da06bdd8f5b4c3f0fd (diff)
downloadwebol-1cd2a8e4aecfaad2a8385a6bea61580209b86398.tar
webol-1cd2a8e4aecfaad2a8385a6bea61580209b86398.tar.gz
webol-1cd2a8e4aecfaad2a8385a6bea61580209b86398.zip
Merge pull request #6 from FxQnLr/ping
Ping
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml18
1 files changed, 11 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e772810..1bf823f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,18 +1,22 @@
1[package] 1[package]
2name = "webol" 2name = "webol"
3version = "0.1.0" 3version = "0.2.0"
4edition = "2021" 4edition = "2021"
5 5
6# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html 6# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
7 7
8[dependencies] 8[dependencies]
9axum = { version = "0.6.20", features = ["headers"] } 9axum = { version = "0.6.20", features = ["headers", "ws"] }
10tokio = { version = "1.32.0", features = ["macros", "rt-multi-thread"] } 10tokio = { version = "1.33.0", features = ["macros", "rt-multi-thread"] }
11tracing = "0.1.37" 11tracing = "0.1.40"
12tracing-subscriber = { version = "0.3.17", features = ["env-filter", "local-time", "time"] } 12tracing-subscriber = { version = "0.3.17", features = ["env-filter", "local-time", "time"] }
13time = { version = "0.3.29", features = ["macros"] } 13time = { version = "0.3.30", features = ["macros"] }
14serde = { version = "1.0.188", features = ["derive"] } 14serde = { version = "1.0.190", features = ["derive"] }
15serde_json = "1.0.107" 15serde_json = "1.0.107"
16config = "0.13.3" 16config = "0.13.3"
17once_cell = "1.18.0" 17once_cell = "1.18.0"
18sqlx = { version = "0.7.1", features = ["postgres", "runtime-tokio"]} 18sqlx = { version = "0.7.2", features = ["postgres", "runtime-tokio"]}
19surge-ping = "0.8.0"
20axum-macros = "0.3.8"
21uuid = { version = "1.5.0", features = ["v4", "fast-rng"] }
22dashmap = "5.5.3"