aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorfx <[email protected]>2023-10-08 23:28:10 +0200
committerfx <[email protected]>2023-10-08 23:28:10 +0200
commit920496c85bdf0d017eaf837cbacd136d7d828669 (patch)
tree78e0cd32933d214fd16ad18a333cf7f1ade5a754 /Cargo.toml
parent88bedad2d7c061b707e83d80aa6f0e51817586df (diff)
downloadwebol-920496c85bdf0d017eaf837cbacd136d7d828669.tar
webol-920496c85bdf0d017eaf837cbacd136d7d828669.tar.gz
webol-920496c85bdf0d017eaf837cbacd136d7d828669.zip
base web server
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..d0ba7b1
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,15 @@
1[package]
2name = "webol"
3version = "0.1.0"
4edition = "2021"
5
6# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
7
8[dependencies]
9axum = { version = "0.6.20", features = ["tracing", "headers"] }
10tokio = { version = "1.32.0", features = ["macros", "rt-multi-thread"] }
11tracing = "0.1.37"
12tracing-subscriber = { version = "0.3.17", features = ["env-filter", "local-time", "time"] }
13time = { version = "0.3.29", features = ["macros"] }
14serde = { version = "1.0.188", features = ["derive"] }
15serde_json = "1.0.107"