summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorfxqnlr <[email protected]>2024-06-13 16:54:35 +0200
committerfxqnlr <[email protected]>2024-06-13 16:54:35 +0200
commitc124f9fff690a42ea5fb490e4c7e512ba8448951 (patch)
treef17edd2042d2dc713f3dd6b0bdabbbb2444fc863 /Cargo.toml
parent04cd0aee6d000073e49b80a530a40cdb176f7f10 (diff)
downloadwebol-c124f9fff690a42ea5fb490e4c7e512ba8448951.tar
webol-c124f9fff690a42ea5fb490e4c7e512ba8448951.tar.gz
webol-c124f9fff690a42ea5fb490e4c7e512ba8448951.zip
cargo update + `time` update, fix for `Instant` deprecation
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 68ba060..56794a7 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,7 +7,7 @@ edition = "2021"
7 7
8[dependencies] 8[dependencies]
9axum = { version = "0.7", features = ["ws"] } 9axum = { version = "0.7", features = ["ws"] }
10tokio = { version = "1.37", features = ["macros", "rt-multi-thread"] } 10tokio = { version = "1.38", features = ["macros", "rt-multi-thread"] }
11tracing = "0.1" 11tracing = "0.1"
12tracing-subscriber = { version = "0.3", features = ["env-filter", "local-time", "time"] } 12tracing-subscriber = { version = "0.3", features = ["env-filter", "local-time", "time"] }
13time = { version = "0.3", features = ["macros"] } 13time = { version = "0.3", features = ["macros"] }
@@ -24,4 +24,4 @@ ipnetwork = "0.20"
24mac_address = { version = "1.1", features = ["serde"] } 24mac_address = { version = "1.1", features = ["serde"] }
25tracing-appender = "0.2.3" 25tracing-appender = "0.2.3"
26utoipa = { version = "4.2", features = ["axum_extras"] } 26utoipa = { version = "4.2", features = ["axum_extras"] }
27utoipa-swagger-ui = { version = "6.0", features = ["axum"] } 27utoipa-swagger-ui = { version = "7.0", features = ["axum"] }