diff options
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 31 |
1 files changed, 16 insertions, 15 deletions
@@ -1,22 +1,23 @@ | |||
1 | [package] | 1 | [package] |
2 | name = "webol" | 2 | name = "webol" |
3 | version = "0.3.0" | 3 | version = "0.3.1" |
4 | edition = "2021" | 4 | edition = "2021" |
5 | 5 | ||
6 | # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html | 6 | # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html |
7 | 7 | ||
8 | [dependencies] | 8 | [dependencies] |
9 | axum = { version = "0.6.20", features = ["headers", "ws"] } | 9 | axum = { version = "0.7", features = ["ws"] } |
10 | tokio = { version = "1.33.0", features = ["macros", "rt-multi-thread"] } | 10 | tokio = { version = "1.34", features = ["macros", "rt-multi-thread"] } |
11 | tracing = "0.1.40" | 11 | tracing = "0.1" |
12 | tracing-subscriber = { version = "0.3.17", features = ["env-filter", "local-time", "time"] } | 12 | tracing-subscriber = { version = "0.3", features = ["env-filter", "local-time", "time"] } |
13 | time = { version = "0.3.30", features = ["macros"] } | 13 | time = { version = "0.3", features = ["macros"] } |
14 | serde = { version = "1.0.190", features = ["derive"] } | 14 | serde = { version = "1.0", features = ["derive"] } |
15 | serde_json = "1.0.107" | 15 | serde_json = "1.0" |
16 | config = "0.13.3" | 16 | config = "0.13" |
17 | once_cell = "1.18.0" | 17 | once_cell = "1.18" |
18 | sqlx = { version = "0.7.2", features = ["postgres", "runtime-tokio"]} | 18 | sqlx = { version = "0.7", features = ["postgres", "runtime-tokio"]} |
19 | surge-ping = "0.8.0" | 19 | surge-ping = "0.8" |
20 | axum-macros = "0.3.8" | 20 | axum-macros = "0.4" |
21 | uuid = { version = "1.5.0", features = ["v4", "fast-rng"] } | 21 | uuid = { version = "1.6", features = ["v4", "fast-rng"] } |
22 | dashmap = "5.5.3" | 22 | dashmap = "5.5" |
23 | color-eyre = "0.6" | ||